Subscriber & Member Login

Login, or register today to interact in our online community, comment on articles, receive our newsletter, manage your account online and more!

Atlas Code 55 Turnout "glitch"

627 views
2 replies
1 rating 2 rating 3 rating 4 rating 5 rating
  • Member since
    April 2003
  • 302,230 posts
Atlas Code 55 Turnout "glitch"
Posted by Anonymous on Sunday, March 17, 2002 5:09 PM
Ok, up until now I have been grateful to Atlas for producing fine quality track. But this new code 55 stuff sucks. I dont know if anyone else has had this problem, but trying to join a rail to the straight route, after the frog, and the rail pops out!! Like it wasnt secured too well to begin with. That, and when I run a train through (without low profile wheelsets because I havent gotten that far yet), the train drags because the flanges pick every singe spike. SUCKS I tell ya!! Next time, Ill go with Peco or ME.

Matt
  • Member since
    January 2001
  • From: Niue
  • 735 posts
Posted by thirdrail1 on Sunday, March 17, 2002 6:38 PM
Sure has been plenty said about this on the Atlas N Scale Forum. Haven't I seen your name over there? There is definitely a compatibility problem.
"The public be ***ed, it's the Pennsylvania Railroad I'm competing with." - W.K.Vanderbilt
  • Member since
    April 2003
  • 302,230 posts
Posted by Anonymous on Monday, March 18, 2002 12:56 AM
Ironic, isn't it? As I understand it, the incompatability problem came about due to a last minute change because the rails wouldn't stay in.

Subscriber & Member Login

Login, or register today to interact in our online community, comment on articles, receive our newsletter, manage your account online and more!

Search the Community

ADVERTISEMENT
ADVERTISEMENT
ADVERTISEMENT
Model Railroader Newsletter See all
Sign up for our FREE e-newsletter and get model railroad news in your inbox!