MTH ps2.0 circuit board replacements?

|
Want to post a reply to this topic?
Login or register for an acount to join our online community today!

MTH ps2.0 circuit board replacements?

  • I have a railking gs-4 that has apparently blown a circuit board(s).  The part number is AE-0000001.   MTH says that part isn't made anymore, but I'm wondering if anyone out there knows who might have one?

    Thanks!

    Replies to this thread are ordered from "oldest to newest".   To reverse this order, click here.
    To learn about more about sorting options, visit our FAQ page.
  • Are you sure it blew the circuit board? SoapBox That gets expensive!!!

    The battery might be too low inside the engine or tender (if it is steam engine), try recharging the battery before doing anything else! Did an MTH factory trained repair shop diagnose the problem for you, or was it a non-MTH trained person?

    Another problem I have run into when using command control, is this, a lighted caboose gave me some problems before I fiqured out it has shorted at the center rail pick-up assembly, it was smoking as it got that hot. What it did was give me problems when using the PS-2 engine in command mode, made me think that a circuit board could have been fried, as it would stop on it's own at times without any warning. Finally I run just the engine and tender and everything was fine, no problems at all. Check all your freight cars that are being used with that train and see what happens when you take each one off, one at a time.

    Lee F.

    Interested in southest Pennsylvania railroads; Reading & Northern, Reading Company, Reading Lines, Philadelphia & Reading.
  • pretty sure it's the board.  I have no sound at all when power is applied.  I have no locomotive light.  I have no smoke.  All I get is a very quiet cross between a hum and a buzz when track power is applied.   After taking off the shell, I found I could put a lead on one side of the motor and another lead to a pickup roller and get the motor moving, but only in forward.  I could also do the same trick by touching a lead to the smoke unit and get it to heat up.  But other than that, nothing....

  • Have you tried to push-in the miniture connectors? Sometimes a small connector that is partially undone will act like a circuit board has failed.

    Are all the wheels clean on your engine? An engine with a lot of operating time will have dirt build-up and a smoking engine builds up dirt faster on the wheels and tracks.

    Be carefull when putting track power straight to a motor in the newer locomotives, as these are D.C. powered. The circuit board has a diode or bridge rectifier inside it to absorb the A.C. and not harm the motors.

    Also use a multimeter to test where you have voltage or don't have voltage. A PS-2 engine will work in non-command mode, just won't have all the features of command control.

    Lee F.

    Interested in southest Pennsylvania railroads; Reading & Northern, Reading Company, Reading Lines, Philadelphia & Reading.