Trains.com

Subscriber & Member Login

Login, or register today to interact in our online community, comment on articles, receive our newsletter, manage your account online and more!

Nscale Atlas Alco S2 with sound runs bad

462 views
4 replies
1 rating 2 rating 3 rating 4 rating 5 rating
  • Member since
    June 2006
  • 68 posts
Nscale Atlas Alco S2 with sound runs bad
Posted by Burbank Bill on Monday, July 25, 2022 6:16 PM

Hello:

I have the atlas s2 with sound and it runs terribly, sound cuts in and out, very jerky running.

Does anyone know how to get this loco to run good, my other locos run on the same track flawless although they have no sound.

Bill

  • Member since
    March 2012
  • 933 posts
Posted by PC101 on Monday, July 25, 2022 8:05 PM

Have you checked the wheels for any tarnish?

If no tarnish is found, clean them anyway.

Put the new loco upside down in a cradle and with two alligator clamp jumper wires attached to your two rails of ''good'' track, power up and touch the loco's left and right wheels of one of the trucks with the other ends of the jumpers and see if it runs better or the same. Go down the line of left and right wheel sets and touch the other wheel sets and see if the Loco runs better or the same.

EDIT: you may need someone else to run up the throttle while you hold the jumper wire ends against the wheel sets.

  • Member since
    August 2011
  • From: A Comfy Cave, New Zealand
  • 5,377 posts
Posted by "JaBear" on Monday, July 25, 2022 8:13 PM

I'd also be checking the electrical pickup as well.

My 2 CentsCheers, the Bear.Smile

"One difference between pessimists and optimists is that while pessimists are more often right, optimists have far more fun."

  • Member since
    September 2004
  • From: Dearborn Station
  • 23,060 posts
Posted by richhotrain on Tuesday, July 26, 2022 5:45 AM

I'd also be checking the electrical pickup as well.

My 2 CentsCheers, the Bear.Smile

 

Gotta be, based upon the information provided to us.

Rich

Alton Junction

  • Member since
    June 2006
  • 68 posts
Posted by Burbank Bill on Tuesday, July 26, 2022 5:49 PM

OK I'll try that thanks

Subscriber & Member Login

Login, or register today to interact in our online community, comment on articles, receive our newsletter, manage your account online and more!

Users Online

There are no community member online

Search the Community

ADVERTISEMENT
ADVERTISEMENT
ADVERTISEMENT
Model Railroader Newsletter See all
Sign up for our FREE e-newsletter and get model railroad news in your inbox!