Trains.com

Subscriber & Member Login

Login, or register today to interact in our online community, comment on articles, receive our newsletter, manage your account online and more!

Prodigy Advance Reset?

1955 views
4 replies
1 rating 2 rating 3 rating 4 rating 5 rating
  • Member since
    January 2008
  • 116 posts
Prodigy Advance Reset?
Posted by leejax01 on Saturday, February 23, 2008 7:54 AM

I rescently repurchased another Prodigy Advance DCC system. It makes my second one and I did also have a Digitrax radio Super Chief after I sold the first Prodigy, but it was an overkill at home. This one was slightly used and the previous guy did not have instructions. It does not matter what engine nor address, the locos don't get full power. My Atlas sound engines don't even start up, they try and cut immediately off. I assume the previous guy messed up the programming.

 

Is there a reset sequence for it or do I need to take it back and get my money back? It is the same layout as previous and even wiring to a short piece of track to test the engines makes no difference.

  • Member since
    September 2007
  • From: Charlotte, NC
  • 6,099 posts
Posted by Phoebe Vet on Saturday, February 23, 2008 10:46 AM

If you go to this website, you can download the manual:

http://www.modelrectifier.com/search/product-view.asp?ID=1990

 

Dave

Lackawanna Route of the Phoebe Snow

  • Member since
    January 2008
  • 116 posts
Posted by leejax01 on Saturday, February 23, 2008 10:49 AM
I have the manual from the first one that I had, but I must have missed it as I read it late this morning. I will read it again, but I did not remember reading it.
  • Member since
    January 2004
  • 790 posts
Posted by Tilden on Saturday, February 23, 2008 1:08 PM

  Make sure you are connecting the track to the track outputs and not the program track outputs.  The program track doesn't put out enough power to run anything.

Tilden

  • Member since
    January 2008
  • 116 posts
Posted by leejax01 on Saturday, February 23, 2008 10:58 PM
It was a faulty DCC system and I ended up purchasing an NCE PowerCab at the train show here in Jax. today. I also found a descently priced Kato Dash 9. I plugged it up and all works well. Thanks for the replies.

Subscriber & Member Login

Login, or register today to interact in our online community, comment on articles, receive our newsletter, manage your account online and more!

Search the Community

ADVERTISEMENT
ADVERTISEMENT
ADVERTISEMENT
Model Railroader Newsletter See all
Sign up for our FREE e-newsletter and get model railroad news in your inbox!