Subscriber & Member Login

Login, or register today to interact in our online community, comment on articles, receive our newsletter, manage your account online and more!

Installing sound in the Broadway LTD GE AC 6000 ( Silent Version )

711 views
2 replies
1 rating 2 rating 3 rating 4 rating 5 rating
  • Member since
    June 2007
  • 21 posts
Installing sound in the Broadway LTD GE AC 6000 ( Silent Version )
Posted by BLinny7 on Monday, March 3, 2008 6:10 PM

Hi all I was wondering if anybody has attempted to put a sound decoder in the Silent Version of the Broadway Limited GE AC 6000. I noticed that they already have a place to mount 2 speakers.

  • Member since
    August 2008
  • 6 posts
Posted by gator4506 on Sunday, August 17, 2008 8:53 PM
I just posted the same request.  I have two BLI AC6000's (no-sound) in which I would like to install the QSI sound system.  Looking forward to the replies to you question.
  • Member since
    August 2008
  • 6 posts
Posted by gator4506 on Sunday, August 17, 2008 8:56 PM
I just posted the same request.  I have two BLI AC6000's (no-sound) in which I would like to install the QSI sound system.  Looking forward to the replies to you question.  Gator4506

Subscriber & Member Login

Login, or register today to interact in our online community, comment on articles, receive our newsletter, manage your account online and more!

Search the Community

ADVERTISEMENT
ADVERTISEMENT
ADVERTISEMENT
Model Railroader Newsletter See all
Sign up for our FREE e-newsletter and get model railroad news in your inbox!